Sorint.SEC Cyber Security Blog



Vulnerabilita' SAMBA 4

Nella giornata del 12 Marzo 2018 gli sviluppatori Samba hanno rilasciato una nuova versione che corregge due vulnerabilità critiche:

 

  • DOS ATTACK ON EXTERNAL PRINT SERVER
    • Versione Affetta: >= 4.0.0
    • CVE: CVE-2018-1050
    • Sintesi: Un mancato controllo dei null pointer può portare ad un crash del Print Server esterno

 

Quando il servizio RPC spoolss è configurato come demone esterno, una mancata sanificazione dell'input, di alcuni parametri delle chiamate RPC, può causare un crash del servizio.

La vulnerabilità è di tipo DoS (Denied of Service) e non può essere sfruttata in altri modi

Se il servizio è configurato come da default, come demone interno, un client può causare il crash solo della sua connessione.

  

  • AUTHENTICATED USER CAN CHANGE OTHER USERS' PASSWORD
    • Versione affetta: > 4.0.0
    • CVE: CVE-2018-1057
    • Sintesi: Su Samba 4 AD DC, un qualsiasi utente autenticato può cambiare la password di tutti gli altri utenti, compresi gli amministratori

 

Su Samba 4 Active Directory DC, il server LDAP non valida correttamente i permessi di modifica delle password in LDAP, permettendo così a qualsiasi utente autenticato di cambiare le password degli altri utenti, comprese le utenze amministrative e account di servizi - Domain Controllers.

 

 COME DIFENDERSI

 Per entrambe le versioni è stata rilasciata una patch ufficiale: Samba Security Releases

 Sono state inoltre rilasciate le versioni 4.7.64.6.14 e 4.5.16 che risolvono le vulnerabilità.

 Per le versioni precedenti fare riferimento alle patch.

 

  • DOS ATTACK ON EXTERNAL PRINT SERVER

Un possibile workaround per l'attacco di tipo DoS è assicurarsi che non sia impostato il parametro rpc_server:spoolss = external nella sezione global del file di configurazione smb.conf.

  

  • AUTHENTICATED USER CAN CHANGE OTHER USERS' PASSWORD

Per maggiori informazioni è possibile fare riferimento alla wiki ufficiale Samba.

 

RIFERIMENTI

14 March 2018